Please recreate recovery record? (SOLVED)

Twice I have tried “MailStoreHome.exe /recreaterecoveryrecords” but I continue to receive an error message:

"647 messages verified.
Verify recovery records
Checking property file rr.prop
Property file rr.prop ok.
Verifying Mid Range 0 - 9999
Database and Recovery Records are not in sync. 
Please recreate recovery record for this archive store."`

I had a complete PC crash and I had to perform a clean installation of Windows 10 Pro. I have reinstalled MailStore Home but I can not access my previous archive of almost 650 emails which spans multiple years. The .rr files and the .dat files are there in the folder but they do not appear in the main window of MailStore Home.

THANK YOU!!!

@yrralrellim
Hi Larry,

Will this Topic help?


MichaelMailStore Support Engineer

Oct '18

Hi @perfguy

Solution:

to recreate the recovery records you can start MailStore Home with this parameter:

MailStoreHome.exe /recreaterecoveryrecords

Peter E.

1 Like

I had previously investigated that “command” thread but my thought at the time I used it was that it did not function for me. After your reply I tried the command again and I am back in business! Thank you. Previously I had my folders named with a date on each backup. Now I have all of my emails in the archive but that are categorized strictly by eamil address. Results = problem solved!

THANKS AGAIN!

Hi Larry,

Thanks for the feedback. A welcome but unexpected surprise.
I can’t take any credit for your eventual outcome - it’s strictly due to your persistence.
You can pat yourself on the back added with some more from me :grinning:

Don’ t know what state my post was in when you visited here,
but I had deleted the post at one point, since you already tried the “solution” twice.
Your description of the path was more explicit than in the post I referred to.

When- and after- I read your feedback , I undeleted my post to make the thread understandable.
Most unusual procedure haha…

I don’t know if you - as the author- can edit the Subject of your post by adding (Solved)
Never really tried that tbh

Best,

Peter E

I believe the original title now shows as “solved”. I didn’t know that I could go back and edit the original post but apparently it worked. Thanks for the tip!

Hi Larry,
Thanks for the feedback.Not sure how the “Solved” got in there,
but “illustrated” , a normal edit of the contents is like this
For a content edit, use the Marker icon in the top screenshot.
To expand the choices , click the 3 dots
MSH-Post-Icons-ab
I understand, that as the author of the 1st post, you can also edit the subject/Topic
There will be an edit marker as well - in the Topic “box”…
MSH-Post-Icons-Topic

1 Like