Gmail issue just started

Hello MailStore Home Community. I’m new here, just signed up so I could get some help with my Gmail issue. Thanks in advance for any/all help I get here.

I’ve been using MailStore Home with my Gmail account for years with no issues. Yesterday I was unable to connect and download any/new messages to MSH. I thought it must have something to do with Google not supporting 3rd party apps anymore?

I run MSH in portable mode, so I renamed the current working MSH folder, downloaded a fresh copy of MSH, ran installer, created a new portable copy on my storage drive. Ran MSH, add my Gmail profile. I had to allow MSH to work with Gmail at a browser popup which was successful.

At first it didn’t work, came up with an error about not being able to access All Mail. I went into Gmail settings, had to check the box for Show in IMAP for All Mail under the Labels tab. All these years it’s never been checked and has always worked fine. Not sure why it’s messed up now.

Now MSH is once again downloading my messages but it’s not showing them in their original folders/label structure like it did before. I ended up with just two folders/labels, Inbox and Send Items. Now I have several thousand messages in the one Inbox folder/label. That’s crazy!

Do I need to run an older copy of MSH to get my folder/label structure back in MSH?

I’d attach a screenshot of my original MSH folder/label structure but don’t see how to do that. Is it possible to attach a file?

Thanks, PB

Hi @Panic_Button ,

I´ll start with the easy one.(Last paragraph)
MSH-Graphic in Post-M

The one about archiving only 2 folders is somewhat (actually quite a bit) harder.
That has been in existence for a couple of years now.
I would have to search to find the exact version number where the change took place.
There are several posts on the forum about it.

No, rather not because you’d be missing out on all the improvements that were in subsequent updates.

There is a way around this to use IMAP Mailbox under Advanced.
However this is/was a hot topic because All Mail takes preference in being archived first
While you can choose your folders,to avoid the same result as you have now,
you have to remove All Mail from the folders list.
There are many posts about this on the forum.

At the moment I don’t have the time to find all the links to those posts.

In short that’s the story about this.

Peter E

1 Like

Thank you Peter and I tried to attach two screenshots but it seems I don’t have permission.

Gmail has been setup for years as you describe. All Mail unchecked, all the folders/labels I want to archive are checked for Show in IMAP.

This just started when Google stopped supporting 3rd party apps for logging in with username and password, which is how MSH has been doing all this time. I can only think that Google has done something to cause this behavior.

If I can’t get this fixed, I may have to find an alterative app to MSH. I’d hate to do that, as MSH has worked perfectly for me for years. I have many folder/labels in my mail structure, so having everything in one folder/label isn’t going to work very well for me.

I will delete my profile and try adding it again using the Advanced feature and see what happens. I did look at it and I need to figure out what all I need to fill out the boxes manually, as I’ve never used the Advanced feature before.

Thanks, PB

Thanks for the feedback.

Funny thing that I ran into the same problem with the graphics in my post above.
2nd time went alright.
Try 1 graphic at a time…

I had to create an App password and fill in MailStore Home for the app.
See if you can find this under your Gmail profile - Security.
Then again - you are already at the stage where you can use your regular pw because
of logging in with Google.

The creation of only 2 folders has nothing to do with it.
This has to do with MSH and using a gmail profile.

The IMAP Mailbox is a separate entity.

MSH-IMAP Mailbox
For Folder selection , click the button in the Folders section
If applicable tick " Also archive unread messages".
Delete is marked but use only if you need deletion at source (server)


MSH-Select Folders
Click “Show Effective Folders”
If All Mail is in that list remove it, if you don’t .it will take priority.
Remove it by adding it to the excluded folders list.

Hope my description is clear enough.

Peter E.

Thanks again Peter for your help. As for:

“I had to create an App password and fill in MailStore Home for the app.
See if you can find this under your Gmail profile - Security.
Then again - you are already at the stage where you can use your regular pw because
of logging in with Google.”

The only place I can find Security is in my Google Account, not Gmail. There’s no way I can see how to add anything, but MailStore Home shows it has access to Gmail, so I don’t think I need to do anything more there?

As for using Advanced IMAP Mailbox, I was not able to make a connection, it failed. In the host box I used (smtp.gmail.com) I think that’s what it wanted? I tried several different things but nothing worked. I can only think since it wants a username and password, that why it’s not working since Google doesn’t support that anymore.

If I can figure out how to make the connection work, then I should be able to do the rest of what you describe for selecting folders. It’s been so long since I originally setup MSH, I can’t recall if using Advanced IMAP MailBox is how I set it up then, it probably is.

As for attachments, I did try one at a time but didn’t work. I also tried to add a picture to my profile and that didn’t work either. I use Brave as my browser and I’ve found it interferes with certain things on certain websites. I will try Chrome and see what happens later, but adding attachments isn’t very important at this time, getting MSH working properly has priority.

Thanks, PB

Okay, I finally figured out what you were referring to on how to add a password for an app. When I was at that page, the Select App and Select Device looked greyed out so I didn’t understand how to use it.

I did try Other Custom Name, entered MailStore Home as you said, it generated a 16 digit code, which I guess you ignore the spaces? I then tried to create a new profile using Advanced / IMAP Mailbox, used the new generated password with no spaces but when I click the Test button it doesn’t connect, it fails. I’m not sure if I’m using the correct info in the Host box of smtp.gmail.com

I have two step verification turned on and I did not get anything popping up on my phone, maybe I need to turn that off?

Cheers, PB

Success! I finally got it working. Now I have my folder/label structure back.

It seems I was using the wrong address in the Host box. I switched to imap.gmail.com and I had to change from the default IMAP-TLS to IMAP-SSL in the Access via box too.

I also unchecked the box for All Maill to show in IMAP in the Gmail settings under the Labels tab.

Thanks Peter for your help. What a pain in the backside this has been.

Cheers, PB

Hi, Thanks for all the feedback.
I’m so glad you got it working.
I commend you for your persistence

One thing I prefer to do differently - Not hiding All Mail in Gmail but instead using the method
I described above.
That way you can check if mails are missing in your archive - eg mail without a label .

Peter E.

PS.Re: Posting images in your post. Due to Brave security.
Find the settings in Brave or use a different browser.
I use Slimjet - Chrome based and no problem.
Try Chrome also .
You can still add them if you want.
As the author of your post the edit button may still be available for you.

Peter E.

Thanks again Peter and as a retired senior, I have time on my hands and don’t give up easily. I’ve been around computers since my first 286 with a 40 meg HDD and one meg of RAM running DOS 5.0. I’m no expert or IT but have an elaborate home network setup. I still take care of my old work computers remotely along with family and friends that are clueless where computers are concerned. One as far away as Maui and I live in Washington State.

I’ve never had to use Googles Add Password feature before, so I wasn’t familiar with it and didn’t understand how it worked at first. Now I know thanks to you and I was able to get SMS Backup+ working on my phone and Pidgin Chat working again too. When Google slammed the door on 3rd party apps, I was scrambling to make things work. I learn something new almost everyday it seems.

As for uploading my profile picture, I tried Chrome, Edge, Firefox, none worked. The picture is under 300 KB and I’ve used it on other sites, so at the moment I’m not sure what’s wrong. I will keep plugging away and see if I can make it work. I can only think it’s not on my end, but something to do with the forum server?

Cheers, PB

Hi there.

I have just downloaded MailStore Home and having the exact problem.

Using the “Advanced > IMAP” option is not working for me - I keep getting the attached error message.

Do any settings need changing on my Google account to make this work? I fear I may need to activate “2 factor authentication” across my whole account, which will not be worth the hassle for me!

Thanks in advance for any help.

2022-09-04 00_14_15-MailStore Home

Google categorizes the login with username & password as “unsafe” because everyone with this combination has access to the whole account.
Therefore, you must enable this setting on the Web page: https://www.google.com/settings/security/lesssecureapps

Thanks Phil. Unfortunately Google removed that setting last May , so it’s no longer an option for MailStore users (https://support.google.com/accounts/answer/6010255?hl).

I’ve done more research. I think the only alternative option is to enable “2 factor authentication” on your Google account, which then allows you to setup what they call an “app password” for less secure apps (https://support.google.com/accounts/answer/185833?hl=en). I haven’t tried it, but I think that’s what Panic_Button is describing above.

2 factor authentication is a hassle for me and probably not used by most people. It’s like “using a hammer to crack a nutshell” for purpose of email backup.

I assume you will never re-enable support for IMAP folders using the ‘standard’ oauth Gmail setup process in MailStore?

Thanks again

Alternatively, you can use our “Gmail” profile, it uses OAuth and does not require a login with username/password.

Thanks Phil. Yes this profile has the problem that it does not bring in the IMAP folders, just the “All mail” folder (which I do not use and do not want to use - With thousands of emails, it is a very messy solution!). I’m afraid I’ll probably have to use another software.

Thanks any way for your help.