Error when archiving

Mailstore Home v12.0.3.14426 (portable)
Win 10


When archiving gmail, I get an error message that the archiving has completed but with errors. The details give this as an error:
“unable to read message headers for a message in folder with date <?> from the IMAP server”

Question: How do I fix this?


Hello @wtr29874,

this error states that the message was unreadable.
It is either defective or the server is not perfectly compliant with the RFC IMAP regulations.

What server/provider are you trying to connect to?
If that is known, maybe there is something more specific to be aware of with this provider.

it is gmail.
Archiving directly from gmail, not using an email client gives this error.

Are you using the GMail profile, or are you connecting to it with generic IMAP?
When you start the profile manually, a progress window pops up.
Wait for the archiving to finish and then do not close it,
instead click on “Details…”, and then “Debug-Log” at the bottom.
In the debug log, please scroll down to a point where this error appears,
so you can see in what folder this mail is.

Have you set the profile to also archive drafts and outbox?

I’m using the gmail profile as determined by mailstore home.

This is an intermittent issue, this error started several weeks ago, usually it would not appear when this profile in mailstore home was run again manually. Then, it would not appear for the next several scheduled runs, then it starts appearing again.

This time when I ran it manually, the error did not go away. I ran the profile manually twice and it still did not go away. This is when I opened a support request. When the error appears, it happens both on scheduled runs and manual runs.

Now, I ran it manually to get the information from the debug log, and the error did not appear. It says the profile completed successfully, without errors.

I also noticed, when it runs without errors, the profile completes in a matter of minutes, but when it encounters this error, it takes 30 minutes or longer to complete, and then the error shows in the popup.

If the error appears again, I will post here again for additional help.


Hello @wtr29874,

this indicates that either the network connection becomes instable while archiving, so that all of a sudden a mail cannot be transmitted completely and no further response is received,

or more likely some other service or application is interfering.

Since this is a web based connection (hhtps), there are applications and services that might scan the connection and cause issues.

Do you have any third party security/antivirus solution installed, instead of the integrated Windows Defender?
Please check whether this solutions has a feature that scans https connections.
In the case you can name the vendor and product of your security solution, I might help investigating if such a feature exists. If possible, limit it to not monitor MailStore Home connections or disable that function if it cannot be simply limited.

Do you have a router/firewall configuration that scans web connections for malware?
This would be a similar situation to the local AV solution above.
Please disable that scanning of https connections, at least to GMail in this case.
If you can name the vendor/product, I might also have a look whether there are any features behaving this way.

The name of the AV is Norton Security Premium

It seems Norton is having a feature called “HTTPS inspection”:

It seems that in “Security” - “Advanced”, there are options like

  • E-Mail Antivirus
  • HTTPS inspector

I am careful with recommending to disable these options,
but you might want to run some tests while disabling these features to narrow down the issue.

HTTPS Inspector might be monitoring any ecrypted web connection and block/modify anything it finds suspicious. Since GMail uses HTTPS as a protocol to communicate messages with this API we are using, this might happen unintendedly.

E-Mail Antivirus might not only monitor classic IMAP/POP3/SMTP connections, but also HTTS GMail protocol, as it is in use for quite a while and widely known, so it could be implemented in Norton.
Then the same issue as with the Inspector might happen here.

Are you willing to test disabling these features and run some archiving runs to compare whether the issue disappears?
If so, this could mean in conclusion that the Norton scan features are too strict and prevent downloading certain files.

I will test and see if that resolves the issue.

I excluded mailstore from detection and scanning, I disabled norton av, then ran mailstore home, and still get the same error message as before.

Are you using a typical internet router to access the internet,
or do you have an advanced setup with a router software that might also scan connections and transported files,
such as pfSense, smoothwall or similar?

it is a typical router.

Mailstore ran on a schedule today and it ran without errors.

Mailstore ran on schedule and the same error returned.

Hi @wtr29874,

what do you mean by “ran on schedule”?
MailStore Home does not offer scheduling.
Are we still talking about MailStore Home, or are you using a different product version, i.e. MailStore Server?

Using win 10 task scheduler Mailstore home runs on a schedule. There are no problems with the scheduling and its running. The error would appear, when it does appear, both when the schedule runs and when it is manually run.

The last few times MailStore Home has run, the error is no longer appearing.

As of today that is the current status of the situation. No more errors being reported by Mailstore home. If the error begins again, I will reopen the post.


Hi @wtr29874,

I was just checking so I am not missing any important information.
I know it is possible to start a certain profile via command line,
and some people make use of it by starting it via task scheduler.
This is externally initiated automation.

I will not forbid that, but there will be no official support from MailStore,
this is Windows functionality, so we have no control over the reliability.

Concerning your issue " unable to read message headers for a message in folder with date <?>…"
it technically means that a certain mail cannot be requested, as it contains unreadable data.
How come? That is the symptom we need to find out.

As stated before, AV solutions can be a cause when they have features “sneaking” into mail and web connections searching for threats.
The idea is good, but from a technical point of view, this is a “man-in-the-middle-attack”.
A secure connection is intended to ensure that only two specific sides communicate. A third party app sniffing is a security breach. Many modern systems detect such behaviour, so GMail might be refusing the connection all of a sudden because of a potential attack.
Also, your Norton AV might find suspicious content in a mail and therefor refuse to continue passing on the data - MailStore Home is then of course not able to read anything anymore.

Some AV solutions still operate although they have been deactivated - strange, but seen.
So it is safer to officially deactivate such features or create exclusions in the solution preferences.
In your case with Norton, there should be features “HTTPS Inspector” and “M-Mail Antivirus”.
To narrow down the issue, you might want to deactivate those two features temporarily and monitor the results.

The other possible cause for such an error message could be that there actually is a defective mail in the mailbox that cannot be read.

Last but not least the connection might be disrupted during archiving.
Does your internet router have a system log where you can check whether there have been unexpected disconnects in a simliar time the error occurred?

Thank you for a thorough response. I am still trying to find “HTTPS Inspector” and “M-Mail Antivirus” in the Norton settings so that I can exclude Mailstore Home. Do you might know where these settings are found in Norton?


I do not have Norton on my systems.
I posted a link earlier where Norton officially states where these features should be found:

This week I got still very few e-mail archieved after my reinstalled Windows 10. To my surprise all e-mails are still not archived from my particular folders. I have selected in maps nor in filters. What should I have done wrong, because It was going very well before that reinstallation?

I am using the Thunderbird version 68.1.2 and MailStore Home version running on Windows 10 version 1903.