Archive of Hotmail account fails following a password change

I’ve been archiving my hotmail account using IMAP for years. Recently I change my email password to make it more complicated. As mentioned the archive worked under the old password (8 lowercase characters and numbers) but returns the following error after switching to the new password (19 upper and lowercase numbers, numbers, and special characters): “LOGIN Invalid credentials (NO)”. The password is the only thing I’ve changed.

Where and how did you change your password?

You have to start at the source.Your Microsoft account.
Since hotmail is really outlook.com, I’ll give a link that describes it for outlook.com
https://support.microsoft.com/en-us/office/change-your-password-in-outlook-com-2138d690-811c-4545-b2f3-e4dbe80c9735
Adapt it for hotmail
. https://support.microsoft.com/en-us/account-billing/change-your-microsoft-account-password-fdde885b-86da-2965-69fd-4871309ef1f1

Short video https://www.youtube.com/watch?v=e1X4Uyhv9Ew

Can you still get directly into your webmail with the new password?
Once you get that straightened out , apply the change to the profile in MailStore Home…

Peter E.

Thank you for your response.

I read the articles and watched the video and I do understand the process. I understand that my hotmail/outlook email account is directly linked to my Microsoft account and changing it affects all my Microsoft logins. To answer your question I changed my password some time ago and at that time I went to each of my apps and set the new password. Those included:

  • Home and work PCs
  • Webmail
  • PC mail client app
  • iPhone mail client
  • Visual Studio IDE

In all instances I simply entered the new password and they logged in without issue and have been continuing to work for over a year.

With respect to MailStore this is the first time I’ve tried to archive my mailbox since my password change. I simply went to the profile and set the new value in the password box and hit test. It failed. I’ve typed it numerous times, copied and pasted it, etc. with no success. No other changes were made.

I appreciate any help you can give.

Hi Chris,

Thanks for your detailed response.

I have some more questions:

  1. Asked already: Can you still get directly into your webmail with the new password?
    2.Which mail protocol are you using?
    Exchange or IMAP (via Advanced > IMAP Mailbox)

My automatic setup defaults to Exchange - it works for me but prefer IMAP
so used IMAP Mailbox as noted above.
For a test I did both and MSH archived successfully accordingly.

I’m sorry , but can’t explain the failure in your case.

I hadn’t commented on the use of 1 password for all the devices, but think
it’s assinine, This is Microsoft who insists on security and then burdens you
with a ridiculous setup that uses 1 password for all those devices…
Have you ever questioned that?

Peter E.

Thanks, Peter,

I assume when you refer to “webmail” you’re asking if I’m able to access my account by navigating to the https://outlook.live.com/mail website. The answer is yes.

As for the protocol I’ve been using the IMAP protocol. Below are my settings:

  • E-mail Address: {my email address}
  • Host: imap-mail.outlook.com
  • Access via: IMAP-SSL
  • Accept all certificates FALSE
  • User Name: {my email address}
  • Password: {my new more complicated password}

I also found an article from around 2018 about how to setup a hotmail/outlook account via POP3 and tried that but that had the same result.

Are you saying it’s possible to setup a hotmail/outlook account using the Exchange adapter? If so, how would I go about doing that?

I’m a programmer by trade so I have some experience with sending HTML requests. If I had to bet money I would say this is some sort of encoding issue. As I mentioned earlier my password contains a number of symbols a couple of which are used as special characters in HTML requests. I’m not trying to come off as accusatory but if MailStore is not properly encoding the password when it sends it off to Microsoft that may be why it’s being refused. I really don’t want to change my password to something less complicated to test that theory but I would bet money on it.

Chris

Hi Chris,

Thanks very much for your feedback - Again as before nicely detailed and organized .
I knew in a glance that you’re not an average user.

As mentioned before, my automatic setup defaults to Exchange Mailbox
Access via HTTPS
Host set to Auto Detect.

Under Advanced Exchange is also available and IMAP Mailbox as well.
Using IMAP Mailbox
I have Host as (believe it or not) outlook.com
Access via IMAP-SSL Not ticked > Accept all certificates

I do have a long password but no symbols , so you may well be correct that if MSH doesn’t encode
the password as required - even the slightest change will result in refusal…

Microsoft accepts it for all the others - Why not MSH?

Did you get a notice from Microsoft on any of your mail apps to use a temp access code
to verify that it is indeed you as authorized user to access Hotmail via MSH?

Some mail providers require an app password, but I used the regular password for my Microsoft - and
Outlook.com account.

There is that option as well - not sure if needed in this case.
Name for the app > MailStore Home
Will provide a link just in case.
https://support.microsoft.com/en-us/account-billing/using-app-passwords-with-apps-that-don-t-support-two-step-verification-5896ed9b-4263-e681-128a-a6f2979a7944

Peter E.

Sorry it took so long to respond. I tried using “Exchange Mailbox” under Advanced with all the suggested settings (and several variations) with no success. I’m personally convinced it has to do with encoding and the user of symbols in the password.

With any luck I’m hoping someone on the development team will see this thread and test that theory. Seems to me it would be something that could very easily be tested.

Chris

Thanks very much for your followup .
We all have our respective obligations…

I too was hoping for an interjection by MailStore staff.
Maybe transcoding of symbols in a password wasn´t implemented
and is known by MailStore since this is seldom used.

You could try an open message in this thread or PM to eg @Dave
and request clarification mentioning this thread and topic.
(Click on the @Dave link and select Message in the upper RH corner)

Good luck.
This is as much as I can do.

Peter E.

Peter,

Thanks again for all your help on this. I tried the @Dave link like you suggested but I don’t see a “Message” link in the upper corner. Perhaps referencing him in this response is enough to get his attention.

Chris

Chris,

Thanks for the praise- I try to do what I can.

Not sure how you can miss it… or why it doesn’t show.

MSH-Forum-Dave-PM

Take care,

Peter E

I’m just special I guess.
image

Hi Chris,

Yes, you’re special alright ,but excluded.
You can’t send a PM. maybe not enough credentials or Badges yet…

Also on your screenshot it looks like you’re not logged in.
See the differences in the headers on both graphics.
But you would have to be, otherwise you can’t post anything.
Maybe a matter of your settings in your forum profile.

Peter E.

Hello!

As far as I know Outlook.com is moving to requiring app-specific passwords. It is entirely possible that the other applications you’re using use OAuth2 to authenticate, this should be the case with the iPhone mail client and Visual Studio IDE for example.

Please try setting up an App-Specific Password and use that password in MailStore.

Thank you gentlemen. The app-specific password did the trick. Thanks for taking the time to assist me.

Chris

1 Like